
<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KCWFVTT');
    

</script>
<!-- End Google Tag Manager -->

     

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#02559a">
<meta name="msapplication-TileColor" content="#02559a">
<meta name="theme-color" content="#ffffff">
    

<title>7 Types of B2B Sales Metrics to Help You | MarketingProfs</title>
    <link rel="stylesheet" href="//css.marketingprofs.com/css/v3/bootstrap.min.css" integrity="sha384-Gn5384xqQ1aoWXA+058RXPxPg6fy4IWvTNh0E263XmFcJlSAwiGgFAW/dAiS6JXm" crossorigin="anonymous">
    <link href="//css.marketingprofs.com/css/v4/mp.min.css?dt=5/27/2021 11:37:22 PM" rel="stylesheet">

	<link rel="dns-prefetch" href="https://www.googletagmanager.com">

<script async id="Cookiebot" src="https://consent.cookiebot.com/uc.js" data-cbid="e5269c15-96e2-4904-9ea7-32f93574fb7b" data-blockingmode="auto" type="text/javascript"></script>
	      
<!-- Custom styles for this template -->

    <script  src="https://s.marketingprofs.com/inc/jscript/v3/jquery-latest.min.js"></script>
      <script type="text/javascript" async src="https://s.marketingprofs.com/inc/jscript/ajax.js"></script>
                <script async type="text/javascript" src="https://s.marketingprofs.com/inc/jscript/v3/global.js?t=5/27/2021 11:37:22 PM"></script>
  <script type="text/javascript" async src="https://api.marketingprofsu.com/lrs/jscript/transaction.js?t=5/27/2021 11:37:22 PM"></script>
    
<style type="text/css">

.bg-image, #storybar { background-image: url(//i.marketingprofs.com/assets/images/site/story/42727_bubbles_lg.jpg);font-weight:bold; }

</style>
    
		    
		    <link rel="canonical" href="https://www.marketingprofs.com/articles/2021/45041/seven-b2b-sales-metrics-that-can-help-you-plan-your-marketing-strategy" />
		<script>varpagetitle = "Seven B2B Sales Metrics That Can Help You Plan Your Marketing Strategy"</script>
		                <!-- BEGIN: Open Graph Meta Data -->
                        <meta property="og:title" content="Seven B2B Sales Metrics That Can Help You Plan Your Marketing Strategy" />
                        <meta property="og:type" content="article" />
                        <meta property="og:image" content="https://i.marketingprofs.com/assets/images/articles/lg/210526-33-straws-lg.jpg" />
                        <meta property="og:url" content="https://www.marketingprofs.com/articles/2021/45041/seven-b2b-sales-metrics-that-can-help-you-plan-your-marketing-strategy" />
                        <meta property="og:description" content="Running a business is hard when your clients are few, and your competition is plenty. Learn about the 7 main sales metrics for a better marketing strategy." />
                        <meta property="og:site_name" content="MarketingProfs" />
                        <meta property="fb:admins" content="100001357263258" />
                        <!-- End: Open Graph Meta Data --> 
		    
			<meta name="description" content="Running a business is hard when your clients are few, and your competition is plenty. Learn about the 7 main sales metrics for a better marketing strategy." />
		
    <script language="javascript" type="text/javascript" src="https://cdns.gigya.com/js/socialize.js?apiKey=2_uPUaN2hpAhlK4g9QTly75isxF5ADxoaZkN64ECjfA2LxxZmXJtqJNOKqoBMngLa0"></script>
    
    <!-- Campaign Web Tracking Code -->


<!--Acoustic -->
<meta name="com.silverpop.brandeddomains" content="www.pages03.net,enterprise.marketingprofs.com,mpb2b.marketingprofs.com,pages03.net,www.marketingprofs.com,www.pages03.net" />
<script async src="https://www.sc.pages03.net/lp/static/js/iMAWebCookie.js?3a40ee8-152a3a41051-2d617ac8ac4460b9f143347708bf4d50&h=www.pages03.net" type="text/javascript"></script>
</head>

<body>
    
    <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KCWFVTT"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    

<header id="top-header">
   

  <div id="fixed-items">
  <nav id="main-nav" class="navbar navbar-expand-lg navbar-light navbar-static align-self-center">
<a class="navbar-brand" href="/"> <img src="//www.marketingprofs.com/assets/images/site/logos/mp_logo.svg" alt="MarketingProfs" class="mp-p75" /></a>
<button id="navbarSideButton" class="navbar-toggler" type="button" data-toggle="collapse" data-target="#mainnav" aria-controls="mainnav" aria-expanded="false" aria-label="Toggle navigation"> <span class="navbar-toggler-icon"></span> </button>
<div class="collapse navbar-collapse pull-right flex-column align-items-end" id="navbarSide">
<a href="/" onclick="return false;" class="closenav ion-android-close p-2"></a>
<form action="/resources/" class="search-form p-xl-3">
     <div class="search-form">
     <div class="form-group has-feedback">
     <label for="topsearch" class="sr-only">Search</label>
     <input class="form-control" name="search" id="topsearch" placeholder="Search..." type="text" />
     <span class="ion-ios-search-strong form-control-feedback"></span>
     </div>
     </div>
</form>
<script>
$('#topsearch').keydown(function (e){
if(e.keyCode == 13)
{
window.location.href='/resources/?loc=nav&search='+encodeURI(this.value);
return false;
                                       }
})
                                        </script><ul class="navbar-nav mp-nav">
     <li class="nav-item p-md-2 px-xl-4 dropdown navtraining">
     <a class="nav-link" href="/upgrade" id="dropdown10" aria-haspopup="true" aria-expanded="false">TRAINING</a>
     <div class="dropdown-menu" aria-labelledby="dropdown10">
     <a class="dropdown-item" href="/upgrade">Individuals &amp; Small Teams</a>
     <a class="dropdown-item navworkshops" href="/cmp/corp/training/sa/" target="_blank">Enterprise Training</a>
     <a class="dropdown-item navcourses" href="/training/courses">Course List</a>
     </div>
     </li>
     <li class="nav-item p-md-2 px-xl-4 dropdown navevents">
     <a class="nav-link" href="/events/" id="dropdown12" aria-haspopup="true" aria-expanded="false">EVENTS</a>
     <div class="dropdown-menu" aria-labelledby="dropdown12">
     <a class="dropdown-item navevents" href="/events/">Upcoming Events</a>
     <a class="dropdown-item navb2b" href="https://mpb2b.marketingprofs.com/">B2B Forum</a>
     <a class="dropdown-item navmcseo" href="/masterclass/43171/the-art-of-being-found-seo-for-non-techie-marketers">Master Class: SEO</a>
     <a class="dropdown-item navmcstrategy" href="/masterclass/43662/marketing-strategy-finding-a-sustainable-differential-advantage">Master Class: Strategy</a>
     <a class="dropdown-item navmccjm" href="/masterclass/44061/customer-journey-maps-for-marketers">Master Class: Customer Journey</a>
     <a class="dropdown-item navmcfgs" href="/masterclass/44453/a-marketers-field-guide-to-financial-goal-setting-and-measurement">Master Class: Financial Goal Setting</a>
     <a class="dropdown-item navmcfgs" href="/masterclass/44833/how-to-build-a-standout-brand">Master Class: Branding</a>
     </div>
     </li>
     <li class="nav-item p-md-2 px-xl-4 dropdown navconsulting">
     <a class="nav-link" href="/cmp/dna/overview/sa/" id="dropdown15" aria-haspopup="true" aria-expanded="false">CONSULTING SERVICES</a>
     <div class="dropdown-menu" aria-labelledby="dropdown15" style="width:250px;">
     <a class="dropdown-item navposition" id="lnkinsights" href="/cmp/dna/insights/sa/">Market Research</a>
     <a class="dropdown-item navposition" id="lnkposition" href="/cmp/dna/position/sa/">Positioning &amp; Messaging</a>
     <a class="dropdown-item navexperience" id="lnkexperience" href="/cmp/dna/experience/sa/">Customer Experience (CX)</a>
     <a class="dropdown-item navdemand" id="lnkdemand" href="/cmp/dna/demand/sa/">Demand Generation</a>
     </div>
     </li>
     <li class="nav-item p-md-2 px-xl-4 dropdown mega-menu">
     <a class="nav-link mega-toggle" href="/resources/" id="dropdown06" aria-haspopup="true" aria-expanded="false">RESOURCES</a>
     <div class="dropdown-menu mega" aria-labelledby="dropdown06">
     <!-- Mega dropdown -->
     <div class="container py-lg-3">
     <div class="row">
     <div class="col-lg-3">
     <h5 class="text-dark">Formats</h5>
     <ul class="list-unstyled">
         <li><a class="dropdown-item" href="/resources/type/25/articles/" title="Marketing Articles">Articles</a></li>
         <li><a class="dropdown-item" href="/resources/type/23/courses/" title="Marketing Courses">Courses</a></li>
         <li><a class="dropdown-item" href="/resources/type/20/guides/" title="Marketing Guides and Reports">Guides &amp; Reports</a></li>
         <li><a class="dropdown-item" href="/resources/type/21/infographics-and-charts/" title="Marketing Infographics and Charts">Infographics &amp; Charts</a></li>
         <li><a class="dropdown-item" href="/resources/type/24/learning-paths/" title="Marketing Learning Paths">Learning Paths</a></li>
         <li><a class="dropdown-item" href="/resources/type/26/podcasts/" title="Marketing Podcasts">Podcasts</a></li>
         <li><a class="dropdown-item" href="/resources/type/27/tutorials/" title="Marketing Video Tutorials">Video Tutorials</a></li>
         <li><a class="dropdown-item" href="/resources/type/19/webinars/" title="Marketing Webinars">Webinars</a></li>
         <li><a class="dropdown-item" href="/ea/" title="Know-How Exchange Discussion Forum">Discussion Forum</a></li>
     </ul>
     <div class="px-4 py-2"><a style="color: #d61c5b;" href="/resources/">Show All &#187;</a></div>
     </div>
     <div class="col-lg-9">
     <h5 class="text-dark">Topics</h5>
     <div class="row">
     <div class="col-lg-4">
     <ul class="list-unstyled">
         <li><a class="dropdown-item" href="/resources/" title="Most Recent Marketing Resources">Most Recent</a></li>
         <li><a href="/resources/topic/160/account-based-marketing" class="dropdown-item" title="Filter resources on Account-Based Marketing">Account-Based Marketing</a></li>
         <li><a href="/resources/topic/161/advertising-promotions" class="dropdown-item" title="Filter resources on Advertising &amp; Promotions">Advertising &amp; Promotions</a></li>
         <li><a href="/resources/topic/162/branding" class="dropdown-item" title="Filter resources on Branding">Branding</a></li>
         <li><a href="/resources/topic/164/career-management" class="dropdown-item" title="Filter resources on Career Management">Career Management</a></li>
         <li><a href="/resources/topic/165/content" class="dropdown-item" title="Filter resources on Content">Content</a></li>
         <li><a href="/resources/topic/166/customer-experience" class="dropdown-item" title="Filter resources on Customer Experience">Customer
         Experience</a></li>
     </ul>
     </div>
     <div class="col-lg-4">
     <ul class="list-unstyled">
         <li><a href="/resources/topic/167/demand-generation" class="dropdown-item" title="Filter resources on Demand Generation">Demand Generation</a></li>
         <li><a href="/resources/topic/168/email" class="dropdown-item" title="Filter resources on Email">Email</a></li>
         <li><a href="/resources/topic/169/events" class="dropdown-item" title="Filter resources on Events">Events</a></li>
         <li><a href="/resources/topic/170/management" class="dropdown-item" title="Filter resources on Management">Management</a></li>
         <li><a href="/resources/topic/171/marketing-strategy" class="dropdown-item" title="Filter resources on Marketing Strategy">Marketing Strategy</a></li>
         <li><a href="/resources/topic/172/marketing-technology" class="dropdown-item" title="Filter resources on Marketing Technology">Marketing Technology</a></li>
         <li><a href="/resources/topic/173/metrics-measurement" class="dropdown-item" title="Filter resources on Metrics &amp; Measurement">Metrics &amp; Measurement</a></li>
     </ul>
     </div>
     <div class="col-lg-4">
     <ul class="list-unstyled">
         <li><a href="/resources/topic/174/mobile" class="dropdown-item" title="Filter resources on Mobile">Mobile</a></li>
         <li><a href="/resources/topic/176/public-relations" class="dropdown-item" title="Filter resources on Public Relations">Public Relations</a></li>
         <li><a href="/resources/topic/177/search" class="dropdown-item" title="Filter resources on Search">Search</a></li>
         <li><a href="/resources/topic/151/social-media" class="dropdown-item" title="Filter resources on Social Media">Social Media</a></li>
         <li><a href="/resources/topic/178/websites" class="dropdown-item" title="Filter resources on Websites">Websites</a></li>
         <li><a href="/resources/topic/64/writing" class="dropdown-item" title="Filter resources on Writing">Writing</a></li>
     </ul>
     </div>
     <div class="col-12">
     <div class="px-4 py-2"><a style="color: #d61c5b;" href="/resources/">Show All &#187;</a></div>
     </div>
     </div>
     </div>
     </div>
     <!-- /.row -->
     </div>
     <!-- /Mega dropdown -->
     </div>
     </li>
     <li class="nav-item account p-md-2 px-xl-4"> <a href="/login" class="nav-link" data-toggle="modal" data-target="#signinModal">SIGN IN</a> </li>
     <li class="nav-item account p-md-2 px-xl-4"> <a href="/login/join" class="nav-link" onclick="window.location.href='/login/join?adref=topnavlnk'; return false;">SIGN UP</a> </li>
</ul>
</div>
<div class="overlay"></div>
</nav>


    <style>#alertDemo{z-index:1000 !important;}
        .dropdown-menu {z-index:1001 !important;
        }
         .cookieconsent-optout-marketing{display:none;}
          .cookieconsent-optout-marketing a {background: #fff !important;padding:7px 5px; border: none !important;color:#2d2b2b;border-radius:3px;}
    </style>
      
        <div id="" class="cookieconsent-optout-marketing alert alert-danger ">
           Please accept all cookies to ensure proper website functionality. <a href="javascript:Cookiebot.renew()">Set my cookie preferences</a>
        </div>
      
  </div>
</header>


					
      
  <style>#main-nav{background:#fff;}</style>     
   
    
 
<div id="page-content">
  <div class="fs-wrapper" >
    <div id="theme" class="bg-image"></div>
       
      <!--end top-->
<main role="main" class="">
      <div class="double-bg-container">
        <div class="container">
                
                        <style>aside h1 {font-size:35px !important;}</style>
                        
          

          <div class="row">
            <div class="col-lg-3 fs-side">
              <aside class="pl-2">
                <div class="slug">Article</div>
                <h1>Seven B2B Sales Metrics That Can Help You Plan Your Marketing Strategy</h1>
                  <p class="blog-post-meta">
                   by <a href="/authors/4291/ian-loew" title="Ian Loew">Ian Loew</a><br><span id="contentdate" itemprop="datePublished" content="2021-5-26">May 26, 2021</span>
                
               </p>
                 <a href="/authors/4291/ian-loew"> <div class="photo"><img src="https://i.marketingprofs.com/assets/images/authors/ian-loew.jpg" width="125px" height="125px" alt="Ian Loew" /></div></a>
              </aside>
            </div>
              <script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "Article",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.marketingprofs.com/articles/2021/45041/seven-b2b-sales-metrics-that-can-help-you-plan-your-marketing-strategy"
  },
  "headline": "Seven B2B Sales Metrics That Can Help You Plan Your Marketing Strategy",
  "image": [
    "https://i.marketingprofs.com/assets/images/articles/lg/210526-33-straws-lg.jpg"
   ],
  "datePublished": "2021-05-26T10:00:00-5:00",
 
  "author": {
    "@type": "Person", 
    "name": "Ian Loew"
  },
   "publisher": {
    "@type": "Organization",
    "name": "MarketingProfs",
    "logo": {
      "@type": "ImageObject",
      "url": "https://i.marketingprofs.com/assets/images/logos/logo_mprofs_bluetransnotag_275x40.png"
    }
  },
  "description": "Running a business is hard when your clients are few, and your competition is plenty. Learn about the 7 main sales metrics for a better marketing strategy.",
  "isAccessibleForFree": "False",
  "hasPart":
    {
    "@type": "WebPageElement",
    "isAccessibleForFree": "False",
    "cssSelector" : ".paywall"
    }
}
</script>
            <div class="col-lg-9 bg-white fs-main">
              <div class="blog-post mb-3 position-relative">
				                
                
<div class="share-widget">
                  <div class="share-widget-inner">
                                
			                        <div class="jssocials-share mp-save">
                                        
                                             <a href="" rel="nofollow" class="jssocials-share-link" data-toggle="modal" data-target="#signinModal"><i class="ion-android-favorite-outline jssocials-share-logo"></i><span class="jssocials-share-label">save</span></a>
                                        
			                        </div>
                                
                    <div id="share"> </div>

                  </div>
                </div>

<script>
    function savecontent(toadd, id)
    {
       if(toadd==1)
            {
                ajaxgo('/content/save.asp?cntid='+id);
                 $('.save-link').addClass('noshow');
                $('.saved-link').removeClass('noshow');
            }
       else
            {
                ajaxgo('/content/save.asp?del=1&cntid='+id);
                 $('.saved-link').addClass('noshow');
                 $('.save-link').removeClass('noshow');
                
            }
    return false;
    }
</script>
                  <div class="articlebody">
                <p>Running a B2B business is challenging when your clients are few and your competition is plenty. Only the best are able to achieve those coveted high conversion rates&#8212;convincing other companies to make a business a part of their vendor pool.</p>
<p>The journey to converting a prospective customer into a client is a long one, marked by multiple discussions. And because of the high value and long-term commitment, B2B sales tend to have lower conversion rates than B2C.</p>
<p>Getting enterprise clients onboard requires planning and a highly targeted approach.</p>
<h2>Seven Sales Metrics for a Better Marketing Strategy</h2>
<p>In this article, I'll be spotlighting B2B sales metrics that can help you crack the coveted 10% conversion rate. Data is your best friend, so make sure you use insights from these metrics to boost your marketing strategy.</p>
<h3>1. Customer Acquisition Cost (CAC)</h3>
<p>Before you can build an effective marketing strategy, you have to know how much it costs to add more clients to your business. Your goal should be to keep the number low because that implies that your strategies are working and you have to spend less money to get customers.</p>
<p>You can calculate CAC by taking the total sales and the marketing costs for a certain period and dividing that by the number of new customers you have added during the same period. For example, if you spend $1,000 on marketing costs in one month to acquire 100 customers in the same period, your CAC is $1,000/100, or $10.</p>
<h3>2. Conversion Rate</h3>
<p>Conversion rate is probably the most important sales metric you'll be tracking. It gives you the proportion of actual purchases or subscriptions to the number of leads, site views, visitors, posts, or emails it took you to get those conversions out of your sales pipeline.</p>
<p>Conversion rate is particularly useful in determining the effectiveness of your marketing efforts. Let's say you use a combination of email marketing, social media, and cold-calling to announce a product launch. Divide the number of conversions (or purchases) you get from each channel by the number of emails, social media posts, and calls you make to see which channel works best for your niche.</p>
<h3>3. Sales Pipeline Velocity</h3>
<p class="paywall">The sales pipeline is the entire sales process, starting when you make the first contact with the buyer and continuing until the deal closes.</p>
<p class="paywall">You can compare the sales pipeline to a boat race. The speed of a boat is the amount of distance it travels over a specific period of time: When your boat goes 20 feet in 2 seconds, its velocity is 10 feet per second. Considering that the average rowboat has a velocity of just under 9 feet per second, your boat (and the rowers and the equipment they use to row it) is pretty fast.</p>
<p class="paywall">Sales pipeline velocity applies the same logic to your sales and marketing process.</p>
<p class="paywall">Since your sales process has a lot of moving parts, calculating the pipeline velocity will be a bit more complicated. To calculate the sales pipeline velocity, use the following formula: SPV = (Number of leads * Average deal value * Win rate) / Sales cycle in days.</p>
<p class="paywall">You want that SPV number to be as high as you can.</p>
<p class="paywall">The longer your sales cycle is (as is the case for B2B businesses compared with B2C), the more you need to compensate with a higher number of leads, a better win rate, or a higher average deal value.</p>
<p class="paywall">For example, if you want to maintain a sales pipeline velocity of $10,000/day and you have just a few leads per sales cycle, you need to either close more high-value deals or shorten your sales cycle.</p>
<h3>4. Average Lead Response Time</h3>
<p class="paywall">You know where your leads are coming from, but what happens once they're in your sales funnel? Is your sales team responding on time? That's what average lead response time measures.</p><p class="paywall"><img src="https://i.marketingprofs.com/assets/images/articles/content/210526-loew-dealhub.jpg" alt="Sales responsiveness stats" /></p>
<p class="paywall">Source: InsideSales</p>
<p class="paywall">The early bird <em>does</em> get the worm, so your sales team should ideally follow up within minutes. Half of all prospective customers choose the business that responds first, a <a target="_blank" href="https://dealhub.io/how-fast-is-your-sales-teams-lead-response-time/">study by Dealhub</a> estimates. Don't go by the industry standard of 61 hours; you'll lose a huge percentage of your leads that way.</p>
<p class="paywall">Use an efficient email workflow system that sends queries to the right person and&#8212;just as important&#8212;stays on top of any social media inquiries. Your <a target="_blank" href="https://lform.com/blog/post/top-5-b2b-web-design-agencies-in-the-united-states">B2B Web design agency</a> should be able to help you set up a process with email notifications, as well as a live chat system that allows site visitors to connect with a representative immediately.</p>
<h3>5. Customer Lifetime Value</h3>
<p class="paywall">You have a new customer, and your sales funnel is working fine. But are new clients staying with you? Customer lifetime value (CLV) is a metric that shows whether your marketing efforts are going beyond the immediate gain of new clients and contributing to long-term growth.</p>
<p class="paywall">You can calculate CLV by multiplying the average length of time a client is with you with the money they spend on your business in each period. You want that number to stay high, because it means you are retaining your clients. For example, if a client spends 10 years with you and spends an average of $1,000 each year, the CLV would be $10,000.</p>
<p class="paywall">CLV is an important metric to consider because client retention is as necessary as client acquisition. If you spend time on acquiring new clients while your existing clients leave in droves, you will always be pumping money through your sales funnel and your CLV will remain low.</p>
<h3>6. Win Rate</h3>
<p class="paywall">I mentioned win rate earlier in this article, in reference to sales pipeline velocity. A lot of people confuse the two; however, though win rate and sales pipeline velocity are related, they are not the same thing.</p>
<p class="paywall">Unlike sales pipeline velocity, which considers average deal size and length of the sales cycle, the win rate is a much simpler metric: Divide the number of wins you've had for a specific period by the total number of sales opportunities during the same span of time, whether or not they were successful.</p>
<p class="paywall">Win rate is particularly useful for comparing your sales performance between two or more periods or market segments. For example, you might find that you have a higher win rate for widgets on Black Friday and Cyber Monday compared with the week after Christmas, or that you sold more lawn mowers per head among suburban customers compared with those who live in apartments.</p>
<p class="paywall">Win rate helps you identify the times when and the areas where you're most likely to make a sale, as well as the sectors or seasons during which you should promote your product more extensively.</p>
<h3>7. Lead Source</h3>
<p class="paywall">This important sales metric helps you know more about the source of your <a target="_blank" href=" https://www.marketingprofs.com/articles/2020/43190/how-b2b-leaders-can-improve-lead-generation-in-their-organizations">lead generation</a> and the amount it contributes to your revenue.</p>
<p class="paywall">For a B2B business, the average conversion rate hovers around 10%. It's a small window of success, so your marketing must be targeted, and you must invest in the right channel. For many companies, email marketing&#8212;a 62% conversion rate&#8212;is an effective way to generate <a target="_blank" href="https://www.marketingprofs.com/articles/2020/43685/b2b-ppc-tactics-six-ways-to-bring-in-higher-quality-leads">quality leads</a>.</p><p class="paywall"><img src="https://i.marketingprofs.com/assets/images/articles/content/210526-loew-venture-harbour.jpg" alt="B2B marketing channel effectiveness by ROI and lead volume" /></p>
<p class="paywall">Source: Venture Harbour</p>
<p class="paywall">Track the source that lands you the most sales opportunities to figure out your strengths and also where you need to improve.</p>
<p class="paywall">Once you have that data, you can further divide it up by how much revenue each source generates. The data will help you get a better return on investment. Knowing the expected revenue from each source also gives you a benchmark to measure your efforts' success against.</p>
<p class="paywall">Track your primary sources of leads, such as <a target="_blank" href="https://www.marketingprofs.com/articles/2020/43531/four-successful-ways-to-combine-inbound-and-outbound-marketing">inbound marketing</a>, paid search, and sales development efforts, so you understand which prospects are coming from where.</p>
<p class="paywall">Once you know which sources are pulling in prospective buyers, it becomes easier to track results and measure the investment return from those sources. It also helps you allocate your funds towards the acquisition source that is bringing in the most interested buyers.</p>
<h2>The Insight of Sales Metrics</h2>
<p class="paywall">Metrics allow you to look more closely at your practices and identify where you are going wrong&#8212;and what you're doing well!</p>
<p class="paywall">All businesses, whether B2B or B2C, have to know who their buyer is, where they can reach that person, and what the person wants. The previously listed B2B sales metrics will help you answer those questions while also giving you insight into your sales funnel and how it is functioning.</p>
<p class="paywall">Use those data insights to polish your marketing strategy, and you'll watch your client numbers climb higher and higher.</p>
<h2>More Resources on Sales Metrics</h2>
<p class="paywall"><a target="_blank" href="https://www.marketingprofs.com/event/34174/take-10-three-sales-metrics-marketing-should-own">Take 10: Three Sales Metrics Marketing Should Own</a></p>
<p class="paywall"><a target="_blank" href="https://www.marketingprofs.com/articles/2020/43916/advanced-measurement-strategies-metrics-that-actually-matter">Advanced Measurement Strategies: Metrics That Actually Matter</a></p>
<p class="paywall"><a target="_blank" href="https://www.marketingprofs.com/chirp/2020/42720/nine-key-sales-pipeline-metrics-for-healthy-sales-infographic">Nine Key Sales Pipeline Metrics for Healthy Sales [Infographic]</a></p>
                  </div>
                                 
                                             <style>.paywall {display:none;
                                                 }


                                             </style>
									              <div style="clear:both">
                                                        
                                                 <style>.lnkreadfull {color:#fff !important}</style>
									             <p style="margin-bottom:100px;">
                                                   
                                                     <b>Continue reading "Seven B2B Sales Metrics That Can Help You Plan Your Marketing Strategy"  ...</b>
                                                     <a style="margin-top:10px;" href="https://www.marketingprofs.com/login/join?source=/articles/2021/45041/seven-b2b-sales-metrics-that-can-help-you-plan-your-marketing-strategy&adref=rdblkfull" rel="nofollow" class="lnkreadfull btn btn-lg btn-block btn-primary mb-3 mb-lg-0">Read the full article
									                </a></p>
                                                
<!--  === main column content starts ===  -->


 


  
    <div class="card-box bg-white funnel-box py-4">
      <div class="mx-5 text-center"><div class="grad-bold my-3" style="font-size:25px;">Subscribe today...it's free!</div><p><b>MarketingProfs provides thousands of marketing resources, entirely free!</b></p><p>Simply subscribe to our newsletter and get instant access to how-to articles, guides, webinars and more for nada, nothing, zip, zilch, on the house...delivered right to your inbox!  MarketingProfs is the largest marketing community in the world, and we are here to help you be a better marketer.</p>
        <div class="funnel-form-wrapper text-left">
          <form id="frmsignup" method="post" action="https://www.marketingprofs.com/login/join" class="needs-validation" novalidate style="margin:0px 10px;">
            <div class="form-row mp-form">
              <div class="form-group col-sm-12" >
                <label for="emailaddress1">Work Email Address</label>
                <input type="email" class="form-control" id="emailaddress1" name="emailaddress1" placeholder="" value="" required>
              </div>
				
            </div>
            
            <div class="text-center">
              <button class="btn btn-primary btn-xlg" type="submit">CONTINUE</button>
             
            </div>
            <div class="text-center small mt-2"> Already a member? <a href="https://www.marketingprofs.com/login" data-toggle="modal" data-target="#signinModal">Sign in now.</a> </div>
              <input type="hidden" name="adref" value="rdblk" ID="adref">		
					<input type="hidden" name="join" value="1" ID="Hidden3">
              <INPUT type="hidden" id="source" name="source" value="/articles/2021/45041/seven-b2b-sales-metrics-that-can-help-you-plan-your-marketing-strategy">
							<INPUT type="hidden" id="joinform" name="joinform" value="1">	
          </form>
         </div>
        <hr class="or">
        <div class="mx-auto" style="width: 250px">
			<style>
			    .gigya-login-provider-row { margin-bottom:10px !important;
			    }
			</style>
          
										
										<div id="oauthLogin" class="center padding">
											<span>Loading...</span>
										</div>
                                        					
					<script language="javascript" type="text/javascript">
						var conf=
						{
							APIKey: '2_uPUaN2hpAhlK4g9QTly75isxF5ADxoaZkN64ECjfA2LxxZmXJtqJNOKqoBMngLa0'
							,enabledProviders: 'facebook,messenger,google,yahoo,twitter'
						}

                        function onGigyaLoadoauthLogin() {  
							// register for login event  
							console.log("gigya init");
							gigya.services.socialize.addEventHandlers(conf, {  
									context: { str: '' }  
									, onLogin: onLoginHandler   
									, onLogout: onLogoutHandler  
									});  
									
							//gigya.services.socialize.isLoggedIn(conf,{ callback: isLoggedIn });
                            gigya.socialize.getUserInfo(conf, { callback: isLoggedInoauthLogin});
						} 
						
						// onLogin Event handler 
						function onLoginHandler(eventObj) {   
							//Nothing for now
						} 	
						
						// onLogout Event handler  
						function onLogoutHandler(eventObj) {  
							//nothing for now
						}  	
						
						// onLogout Event handler  
                        function onErrorHandleroauthLogin(eventObj) {  
						
							if(eventObj.status=='CANCELED')
							{
								document.getElementById('statusdiv').style.display = '';
								document.getElementById('statusdiv').innerHTML = 'You have chosen to not share information ... we cannot create your account.  Try again, or enter your email address on this page.';
							}
						
						}  							
						
                        function isLoggedInoauthLogin(response) {
							//if(!response.loggedIn){
								var login_params=
								{
								    useHTML: 'true'
                                    ,version: 2
									,showTermsLink: 'false'
									,height: 100
									,width: '260'
									,containerID: 'oauthLogin'
									,buttonsStyle: 'fullLogo'
									,hideGigyaLink:true
									,redirectURL: 'https://www.marketingprofs.com/login/openauth?source=%2Farticles%2F2021%2F45041%2Fseven%2Db2b%2Dsales%2Dmetrics%2Dthat%2Dcan%2Dhelp%2Dyou%2Dplan%2Dyour%2Dmarketing%2Dstrategy'
									
                                , onError: onErrorHandleroauthLogin
								}		
								gigya.services.socialize.showLoginUI(conf,login_params);
							//}
						}

						//init
                        $(document).ready(function () {
                            onGigyaLoadoauthLogin();
                        });
						
						
                    </script>	

        </div>
        </div>
      </div>               
 
 
			
  
	
                
               
                    <hr>
       
                    <div id="authors" class="mb-4"><p>ABOUT THE AUTHOR</p> <div class="author-bio media py-2 mb-5"><div class="photo mr-3"><img src="https://i.marketingprofs.com/assets/images/authors/ian-loew.jpg" width="125px" height="125px" alt="image of Ian Loew"></div> <div class="media-body"><p><strong>Ian Loew</strong> is the owner of <a target="_blank" rel="nofollow" href=" https://lform.com/">Lform Design</a>, a B2B Web design and custom Web development company. After four years of helping Fortune 500 companies with MGT Design, Ian embarked on a freelance career before establishing Lform Design in 2005.</p>
<p>LinkedIn: <a target="_blank" rel="nofollow" href="https://www.linkedin.com/in/lform/">Ian Loew</a></p></div> </div></div>
<style>
    #youmaylike h3 a{font-size:1.0em !important;}
    #youmaylike a{font-size:1.3em !important;color:#333;}
    #youmaylike a:hover{text-decoration:underline;}
    #youmaylike ul li {list-style:square !important;}
    #youmaylike ul li {margin-left:20px;}
</style>
                                                            <div id="youmaylike" class="">
<h3><a href="/resources/?catids_1=173" class="trackclick" rel="YML - Header: Metrics & Measurement">Metrics & Measurement Articles</a></h3><p>You may like these other MarketingProfs articles related to Metrics & Measurement:</p> 
<ul>
<li>
<a href="https://www.marketingprofs.com/charts/2021/44890/the-most-difficult-marketing-channels-to-track"  class="trackclick" rel="YML - Link: Metrics & Measurement">The Most Difficult Marketing Channels to Track</a></li>
</li>
<li>
<a href="https://www.marketingprofs.com/articles/2021/44695/top-5-sentiment-analysis-tools"  class="trackclick" rel="YML - Link: Metrics & Measurement">Top 5 Sentiment Analysis Tools</a></li>
</li>
<li>
<a href="https://www.marketingprofs.com/articles/2021/44613/why-you-need-to-align-marketing-to-business-goals"  class="trackclick" rel="YML - Link: Metrics & Measurement">Why You Need to Align Marketing to Business Goals</a></li>
</li>
<li>
<a href="https://www.marketingprofs.com/articles/2021/44563/how-to-develop-an-efficient-post-pandemic-advertising-strategy-with-data-analytics-using-only-a-spreadsheet"  class="trackclick" rel="YML - Link: Metrics & Measurement">How to Develop an Efficient Post-Pandemic Advertising Strategy With Data Analytics Using Only a Spreadsheet</a></li>
</li>
<li>
<a href="https://www.marketingprofs.com/chirp/2021/44377/six-tips-for-measuring-your-linkedin-ad-campaigns-infographic"  class="trackclick" rel="YML - Link: Metrics & Measurement">Six Tips for Measuring Your LinkedIn Ad Campaigns [Infographic]</a></li>
</li>
</ul>
</div>
  
               
                <hr>
                 
                 <div style="margin:20px;" class="text-center">
   
                               <a href="https://www.zedo.com" target="_blank"><img src="/assets/images/misc/zedo_logo.png" style="border:0px;" width="200px" alt="MarketingProfs Partner" /></a>
  
                        </div>
                
                <div id="searchbtm"></div>
        <script>
        $("#searchbtm").load("/search/forms #searchform1");
        </script>
              </div>
              <!-- /.blog-post --> 
              
            </div>
            <!-- /.blog-main --> 
            
            <!-- /.fs main --> 
          </div>
        </div>
      </div>
      <!-- /.double-bg-container -->

</main>
    
<!--start bottom-->
<footer class="footer-1 row">
<div class="container">
<div class="row mb-5 text-center text-md-left">
<div class="col-sm col-lg-2 offset-lg-1 pt-2">
<h5>ABOUT</h5>
<ul class="nav-footer">
     <li class="nav-item"> <a class="nav-link" href="/about/">About Us</a></li>
     <li class="nav-item"> <a class="nav-link" href="/story/">Stories</a></li>
     <li class="nav-item"><a href="/syndication/">RSS Feeds</a></li>
     <li class="nav-item"><a href="/newsletters/marketing/">Newsletters</a></li>
</ul>
</div>
<div class="col-sm col-lg-3 pt-2">
<h5>TRAINING OPTIONS</h5>
<ul class="nav-footer">
     <li class="nav-item"> <a class="nav-link" href="/upgrade">Training Subscriptions</a></li>
     <li class="nav-item"> <a class="nav-link" href="/cmp/corp/training/sa/" target="_blank">Enterprise Training</a></li>
     <li class="nav-item"> <a class="nav-link" href="https://mpb2b.marketingprofs.com" target="_blank">B2B Forum</a></li>
     <li class="nav-item"> <a class="nav-link" href="/events/mwb20/home/sa/">Marketing Writing Bootcamp</a></li>
</ul>
</div>
<div class="col-sm col-lg-3 pt-2">
<h5>PARTNERSHIPS</h5>
<ul class="nav-footer">
     <li class="nav-item"> <a class="nav-link" href="https://services.marketingprofs.com" target="_blank">Lead&nbsp;Gen&nbsp;&amp;&nbsp;Sponsorships</a></li>
     <li class="nav-item"> <a class="nav-link" href="https://mpb2b.marketingprofs.com/sponsorship/" target="_blank">Event Sponsorships</a></li>
     <li class="nav-item"> <a class="nav-link" href="/write-for-us">Write for Us</a></li>
     <li class="nav-item"> <a class="nav-link" href="/speak-for-us">Speak for Us</a></li>
</ul>
</div>
<div class="col-sm col-lg-2 pt-2">
<h5>HELP</h5>
<ul class="nav-footer">
     <li class="nav-item"> <a class="nav-link" href="/about/contact/">Contact Us</a></li>
     <li class="nav-item"> <a class="" href="/ea/">Know-How Exchange</a></li>
     <li class="nav-item"> <a class="" href="/about/refunds">Refund Policy</a></li>
     <li class="nav-item"> <a class="" href="/about/terms-of-use">Terms of Use</a></li>
     <li class="nav-item"> <a class="" href="/about/privacy">Privacy Policy</a></li>
     <li class="nav-item"> <a class="" href="/about/cookie-policy">Cookies Policy</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="copyright col-12 d-flex justify-content-center">
</div>
<div class="copyright col-12 d-flex justify-content-center"><span> <span class="copyrightyear">&#169; 2021</span> MARKETINGPROFS LLC</span><span> ALL RIGHTS RESERVED</span></div>
</div>
</div>
</footer>


  </div><!-- /.fs-wrapper -->
</div><!-- /page-content -->
       
        <div id="storybar" class="bg-image noprint">
          <div class="container-fluid">
	  
            <div class="text-right"><a href="/resources/" onclick="window.location.href ='/story/';return false;">Get access to B2B Forum Online 2021 + a year of PRO.</a></div>
          </div>
        </div>
        
<!-- content --> 

<!-- Bootstrap core JavaScript
    ================================================== --> 
<!-- Placed at the end of the document so the pages load faster --> 

<script async src="https://s.marketingprofs.com/inc/jscript/v3/jquery.easing.min.js"></script> 
<script async src="https://s.marketingprofs.com/inc/jscript/v3/popper.min.js" integrity="sha384-ApNbgh9B+Y1QKtv3Rn7W3mgPxhU9K/ScQsAP7hUibX39j7fakFPskvXusvfa0b4Q" crossorigin="anonymous"></script> 
<!-- Latest compiled and minified JavaScript --> 
<script async src="https://s.marketingprofs.com/inc/jscript/v3/bootstrap.min.js" integrity="sha384-JZR6Spejh4U02d8jOt6vLEHfe/JQGiRRSQQxSfFWpi1MquVdAyjUar5+76PVCmYl" crossorigin="anonymous"></script> 
<script async  src="https://s.marketingprofs.com/inc/jscript/v3/validator.min.js"></script> 
<script async src="//s.marketingprofs.com/inc/jscript/v3/jssocials.min.js"></script> 
<script async src="//s.marketingprofs.com/inc/jscript/v3/mp.js?dt=5/27/2021 11:37:22 PM"></script>

<!-- Bootstrap core CSS -->

    <link rel="stylesheet" href="//css.marketingprofs.com/css/v3/ionicons.min.css?dt=5/27/2021 11:37:22 PM">
<script>
  $(document).ready(function () {
    $('#topsearch').keydown(function (e){
if(e.keyCode == 13)
{
window.location.href='/resources/?loc=nav&search='+encodeURI(this.value);
return false;
                                }
})
})
 </script>



<div class="modal mp-modal fade" id="signinModal" tabindex="-1" role="dialog" aria-labelledby="signinModalLabel" aria-hidden="true">
  <div class="modal-dialog modal-lg modal-dialog-centered" role="document">
    <div class="modal-content">
      <div class="modal-header pb-0">
       
        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
          <span aria-hidden="true">&times;</span>
        </button>
      </div>
      <div class="modal-body">
             <div class="mx-5 text-center"> 
        <div class="modal-title my-3">Sign in to start learning.</div>
        <div class="funnel-form-wrapper text-left">
          <form id="" method="post" action="/login" class="needs-validation" novalidate>
            <div class="mp-form position-relative">
              <div class="form-group">
                <label for="username">Email Address</label>
                <input type="email" class="form-control" id="username" name="username" placeholder="" value="" required>
              </div>
			                   <div class="form-group">
                        <label  for="req_pwd">Password</label>
                        <input class="form-control" id="password" name="password" placeholder="" type="password" required> 
                      </div>
                <div class="form-check">
                <input class="form-check-input" type="checkbox" value="ON" id="savelogin" name="savelogin" checked>
                <label class="form-check-label" for="savelogin">
                <p>Keep me signed in</p>
                </label>
              </div>
				<div class="small forgot-pw mb-2"><a href="/login/forgotpassword">Forgot your password?</a></div>
            </div>
           <input type="hidden" name="source" value="/articles/2021/45041/seven-b2b-sales-metrics-that-can-help-you-plan-your-marketing-strategy" ID="Hidden2">
            <div class="text-center pt-2">
              <button class="btn btn-primary btn-xlg ml-md-5" type="submit">SIGN IN</button>
              <button type="reset" class="btn btn-cancel" data-dismiss="modal" aria-label="Close">Cancel</button>
            </div>
            <div class="text-center small mt-2"> Not yet a registered user? <a href="/login/join?source=/articles/2021/45041/seven-b2b-sales-metrics-that-can-help-you-plan-your-marketing-strategy">Sign up now.</a> </div>
          </form>
        </div>
        <hr class="or">
       <div class="mx-auto modallogin" style="width: 260px;">
            					
					<script language="javascript" type="text/javascript">
						var conf=
						{
							APIKey: '2_uPUaN2hpAhlK4g9QTly75isxF5ADxoaZkN64ECjfA2LxxZmXJtqJNOKqoBMngLa0'
							,enabledProviders: 'facebook,messenger,google,yahoo,twitter'
						}

                        function onGigyaLoadoauthLoginPopup() {  
							// register for login event  
							console.log("gigya init");
							gigya.services.socialize.addEventHandlers(conf, {  
									context: { str: '' }  
									, onLogin: onLoginHandler   
									, onLogout: onLogoutHandler  
									});  
									
							//gigya.services.socialize.isLoggedIn(conf,{ callback: isLoggedIn });
                            gigya.socialize.getUserInfo(conf, { callback: isLoggedInoauthLoginPopup});
						} 
						
						// onLogin Event handler 
						function onLoginHandler(eventObj) {   
							//Nothing for now
						} 	
						
						// onLogout Event handler  
						function onLogoutHandler(eventObj) {  
							//nothing for now
						}  	
						
						// onLogout Event handler  
                        function onErrorHandleroauthLoginPopup(eventObj) {  
						
							if(eventObj.status=='CANCELED')
							{
								document.getElementById('statusdivPopup').style.display = '';
								document.getElementById('statusdivPopup').innerHTML = 'You have chosen to not share information ... we cannot create your account.  Try again, or enter your email address on this page.';
							}
						
						}  							
						
                        function isLoggedInoauthLoginPopup(response) {
							//if(!response.loggedIn){
								var login_params=
								{
								    useHTML: 'true'
                                    ,version: 2
									,showTermsLink: 'false'
									,height: 100
									,width: '290'
									,containerID: 'oauthLoginPopup'
									,buttonsStyle: 'fullLogo'
									,hideGigyaLink:true
									,redirectURL: 'https://www.marketingprofs.com/login/openauth?source=%2Farticles%2F2021%2F45041%2Fseven%2Db2b%2Dsales%2Dmetrics%2Dthat%2Dcan%2Dhelp%2Dyou%2Dplan%2Dyour%2Dmarketing%2Dstrategy'
									
                                , onError: onErrorHandleroauthLoginPopup
								}		
								gigya.services.socialize.showLoginUI(conf,login_params);
							//}
						}

						//init
                        $(document).ready(function () {
                            onGigyaLoadoauthLoginPopup();
                        });
						
						
                    </script>	
	
			        <div id="oauthLoginPopup" class="center" style="margin-top:10px;"><span>Loading...</span></div>
			
          <style>
			    .gigya-login-provider-row { margin-bottom:10px !important;
			    }
              .modallogin .gigya-login-providers {margin-left:-15px;
              }
			</style>
        </div>
      </div>
      </div>
      <div class="modal-footer">
       
      </div>
    </div>
  </div>
</div>



 <div class="mpisregistered" title="0"></div>
     
     <div class="mpuserid" title="0"></div>
     <div class="mplevel" title="0"></div>


<script>
    $(".mpnonmember").show();
</script>

<link rel="stylesheet" href="//css.marketingprofs.com/css/v3/3rdparty-styling.css?dt=">

<script>
    // Exit intent
function addEvent(obj, evt, fn) {
  if (obj.addEventListener) {
    obj.addEventListener(evt, fn, false);
  } else if (obj.attachEvent) {
    obj.attachEvent("on" + evt, fn);
  }
}

// Exit intent trigger
addEvent(document, 'mouseout', function(evt) {
  if( evt.clientY < 0 ) { //another way to detect exit  
  //if (evt.toElement === null && evt.relatedTarget === null) {
                if (getMPCookie('sawexitpopover')!=1){
    		        var enddate = new Date("11/23/2021");
    				setMPCookie('sawexitpopover','1',enddate,'/');
    				 $('#exitModal').modal();
    		   }
  }
});
</script>

<div class="modal mp-modal fade" id="exitModal" tabindex="-1" role="dialog" aria-labelledby="exitModalLabel" aria-hidden="true">
  <div class="modal-dialog modal-lg modal-dialog-centered" role="document">
    <div class="modal-content">
      <div class="modal-header pb-0">
       
        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
          <span aria-hidden="true">&times;</span>
        </button>
      </div>
      <div class="modal-body">
             <div class="mx-5 text-center"> 
                 <img src="//i.marketingprofs.com/assets/images/site/logos/mp_logo.svg" alt="MarketingProfs: Online Marketing Training and Resources" width="250">
         <div class="modal-title my-3">WHOA! Hold on a minute, friend.</div>
                 <p>Don't miss out on the latest marketing tips and techniques, delivered right to your inbox.<br /><b>Subscribe today ... it's free!</b></p>
        <div class="funnel-form-wrapper text-left">
          <form id="frmsignup" method="post" action="/login/signup" class="needs-validation" novalidate>
            <div class="form-row mp-form">
              <div class="form-group col-sm-12" >
                <label for="emailaddress1">Work Email Address</label>
                <input type="email" class="form-control" id="emailaddress1" name="emailaddress1" placeholder="" value="" required>
              </div>
				
            </div>
            
            <div class="text-center">
              <button class="btn btn-primary btn-xlg" type="submit">CONTINUE</button>
             
            </div>
            <div class="text-center small mt-2"> Already a registered user? <a href="/login">Sign in now.</a> </div>
              <input type="hidden" name="adref" value="exit" ID="adref">
              <input type="hidden" name="cmp" value="exitintent" ID="cmp">		
					<input type="hidden" name="join" value="1" ID="Hidden3">
              <INPUT type="hidden" id="source" name="source" value="/articles/2021/45041/seven-b2b-sales-metrics-that-can-help-you-plan-your-marketing-strategy">
							<INPUT type="hidden" id="joinform" name="joinform" value="1">	
          </form>
         </div>
        <hr class="or">
       <div class="mx-auto modallogin" style="width: 260px;">
            					
					<script language="javascript" type="text/javascript">
						var conf=
						{
							APIKey: '2_uPUaN2hpAhlK4g9QTly75isxF5ADxoaZkN64ECjfA2LxxZmXJtqJNOKqoBMngLa0'
							,enabledProviders: 'facebook,messenger,google,yahoo,twitter'
						}

                        function onGigyaLoadoauthLoginPopup2() {  
							// register for login event  
							console.log("gigya init");
							gigya.services.socialize.addEventHandlers(conf, {  
									context: { str: '' }  
									, onLogin: onLoginHandler   
									, onLogout: onLogoutHandler  
									});  
									
							//gigya.services.socialize.isLoggedIn(conf,{ callback: isLoggedIn });
                            gigya.socialize.getUserInfo(conf, { callback: isLoggedInoauthLoginPopup2});
						} 
						
						// onLogin Event handler 
						function onLoginHandler(eventObj) {   
							//Nothing for now
						} 	
						
						// onLogout Event handler  
						function onLogoutHandler(eventObj) {  
							//nothing for now
						}  	
						
						// onLogout Event handler  
                        function onErrorHandleroauthLoginPopup2(eventObj) {  
						
							if(eventObj.status=='CANCELED')
							{
								document.getElementById('statusdivPopup').style.display = '';
								document.getElementById('statusdivPopup').innerHTML = 'You have chosen to not share information ... we cannot create your account.  Try again, or enter your email address on this page.';
							}
						
						}  							
						
                        function isLoggedInoauthLoginPopup2(response) {
							//if(!response.loggedIn){
								var login_params=
								{
								    useHTML: 'true'
                                    ,version: 2
									,showTermsLink: 'false'
									,height: 100
									,width: '290'
									,containerID: 'oauthLoginPopup2'
									,buttonsStyle: 'fullLogo'
									,hideGigyaLink:true
									,redirectURL: 'https://www.marketingprofs.com/login/openauth?source=%2Farticles%2F2021%2F45041%2Fseven%2Db2b%2Dsales%2Dmetrics%2Dthat%2Dcan%2Dhelp%2Dyou%2Dplan%2Dyour%2Dmarketing%2Dstrategy'
									
                                , onError: onErrorHandleroauthLoginPopup2
								}		
								gigya.services.socialize.showLoginUI(conf,login_params);
							//}
						}

						//init
                        $(document).ready(function () {
                            onGigyaLoadoauthLoginPopup2();
                        });
						
						
                    </script>	
	
			        <div id="oauthLoginPopup2" class="center" style="margin-top:10px;"><span>Loading...</span></div>
			
          <style>
			    .gigya-login-provider-row { margin-bottom:10px !important;
			    }
              .modallogin .gigya-login-providers {margin-left:-15px;
              }
			</style>
        </div>
      </div>
      </div>
      <div class="modal-footer">
       
      </div>
    </div>
  </div>
</div>



</body>
</html>
